1

Installation of Bugzilla-3.4.4 on Ubuntu 9.0.4

I had been trying to installed on Ubuntu 9.0.4 since last month by following the instructions that I had blogged some time ago (Installation of Bugzilla in Ubuntu Environment). However, this doesn’t work as what I had expected in the beginning. I think this needs some time to figure out what’s wrong as this works on my Ubuntu last time. So, last night, I tried to install again and discovered a lot of new things during the installation of Bugzilla on Ubuntu 9.0.4. Let’s discover what are the new stuff that we learned from the ‘Bugzilla Installation Journey’ for this time.

    1. As usual, I ran the following command for bugzilla installation:

$ sudo apt-get install bugzilla3

  1. Then, it gets the work done and asked for password to be set for database’s administrative user.
  2. The following is being prompted after provided the password for database’s administrative user:

    | If you customized values in the Status/Resolution field, you must edit │
    │ /usr/share/bugzilla3/lib/checksetup_nondebian.pl before running it. │
    │ Did you customize the Status/Resolutions values? │
    │<Yes>                       <No>

    This is a new request which doesn’t exists in the previous installation. The strange thing is no matter my answer is (‘Yes’) or (‘No’), it doesn’t allows us to proceed to the next step of the installation. Instead, I get the following message:

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    bugzilla3 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up bugzilla3 (3.2.0.1-1) …
    Setup DB connection
    dbconfig-common: writing config to /etc/dbconfig-common/bugzilla3.conf
    Not replacing deleted config file /etc/bugzilla3/dbconfig-params
    dbconfig-common: flushing administrative password
    .: 77: Can’t open /etc/bugzilla3/dbconfig-params
    dpkg: error processing bugzilla3 (–configure):
    subprocess post-installation script returned error exit status 2
    Errors were encountered while processing:
    bugzilla3
    E: Sub-process /usr/bin/dpkg returned an error code (1)



After a further research, it seems that this is a bug that has been fixed in bugzilla 3.2.4.0-3. The bug has been filed at here:

The information about fixing the bug is from the following comment:

Since this is a bug, there is no reason for me to continue running the command: ‘sudo apt-get install bugzilla3‘ which keeps installing the same version (3.2.0.1-1). I planned to remove the entire installation of Bugzilla and restart it from the scratch:
$ sudo apt-get remove bugzilla3


Create Database for Bugzilla in MySQL

    1. Create a user and password for bugzilla

$ sudo useradd -d /home/bugzilla -m bugzilla
$ sudo passwd bugzilla

    1. Access to the mySQL and create the database

$ mysql -u root -p
mysql> create database bugzilla;

    1. Grant the privileges for the database ‘bugzilla’

mysql> grant all privileges on bugzilla.* to bugzilla@localhost;

    1. Edit the localconfig file located in /usr/share/bugzilla-3.4.4 directory

$db_name = 'bugzilla';
$db_name = 'bugzilla';
$db_pass = '';
$webservergroup = '';

If you are not configuring the /etc/apache2/envvars for ‘APACHE_RUN_USER‘ and ‘APACHE_RUN_GROUP‘, you will need to edit it as blank for the $webservergroup = ”;

    1. Run the ./checksetup.pl everytime you changed the configuration. Once the configuration is successful, it will prompt you the following:

Looks like we don’t have an administrator set up yet. Either this is
your first time using Bugzilla, or your administrator’s privileges
might have accidentally been deleted.

Enter the e-mail address of the administrator: admin@bugzilla.com
Enter the real name of the administrator: administrator
Enter a password for the administrator account:
Please retype the password to verify:
admin@bugzilla.com is now set up as an administrator.
Creating default classification ‘Unclassified’…
Creating initial dummy product ‘TestProduct’…

Now that you have installed Bugzilla, you should visit the ‘Parameters’
page (linked in the footer of the Administrator account) to ensure it
is set up as you wish – this includes setting the ‘urlbase’ option to
the correct URL.


Manual Installation of Bugzilla-3.4.4

    1. Since the bug is already fixed in 3.2.4.0-3, I prefer to grab the latest version and download it from here:

http://www.bugzilla.org/download/

    1. Extract the installation folder

$ sudo tar -xvf bugzilla-3.4.4.tar.gz

    1. Move the extracted folder to the intended folder for installation.

$ sudo mv bugzilla-3.4.4 /usr/share

    1. Create a symbolic link

$ sudo ln -s /usr/share/bugzilla-3.4.4 /var/www/bugzilla

    1. Edit the apache2.conf which located in /etc/apache2 directory. If the file does not exists in /etc directory, try to perform the command: locate apache2.conf to find out the location of the file.

$ sudo gedit /etc/apache2/apache2.conf

Add the following lines to configure the apache2.conf:

Alias /bugzilla/ /var/www/bugzilla/
<Directory /var/www/bugzilla>
AddHandler cgi-script .cgi .pl
Options +Indexes +ExecCGI +FollowSymLinks
DirectoryIndex index.cgi
AllowOverride Limit
</Directory>

    1. Run checksetup.pl from the installation directory to ensure there are no missing files and the everything works well.

$ sudo ./checksetup.pl

Once I ran the command, I got the following message:

To attempt an automatic install of every required and optional module
with one command, do:
/usr/bin/perl install-module.pl –all

    1. Install every required and optional module

$ sudo /usr/bin/perl install-module.pl --all

    1. Apache requires to be restarted after the modification of apache2.conf file in order for the changes to take place.

$ sudo /etc/init.d/apache2 restart

    1. Access bugzilla from the following URL:

http://localhost/bugzilla/

or

http://127.0.0.1/bugzilla/

Reference:

http://vibhurishi.blogspot.com/2009/05/howto-install-bugzilla-on-ubuntu-9.html

facebooktwittergoogle_plusredditpinterestlinkedinmailby feather
1 Star2 Stars3 Stars4 Stars5 Stars (No Ratings Yet)
Loading ... Loading ...

chin yee

One Comment

Leave a Reply

Your email address will not be published. Required fields are marked *

Current ye@r *

What is 13 + 6 ?
Please leave these two fields as-is:
IMPORTANT! To be able to proceed, you need to solve the following simple math (so we know that you are a human) :-)